[Android] Beta 2.48.0

Frohe neue Woche. Auch die Android Version geht in die nächste Beta-Phase:

  • Neue Screens bei erfolgreichen Empfehlungen
  • Footprint Kontext Fragen sind jetzt ein- und ausklappbar
  • Ein paar kleinere Bug-fixes

Happy Testing!

Nach dem Update auf Version 2.48.1 crasht die App direkt beim Öffnen bei mir, d.h. ich komme gar nicht auf den Login-Screen.

Exception aus dem LogCat Reader:

FATAL EXCEPTION: main
Process: one.tomorrow.app, PID: 13164
java.lang.UnsatisfiedLinkError: No implementation found for int[] one.tomorrow.app.commons.api.tomorrow.TomorrowNative.d() (tried Java_one_tomorrow_app_commons_api_tomorrow_TomorrowNative_d and Java_one_tomorrow_app_commons_api_tomorrow_TomorrowNative_d__)
	at one.tomorrow.app.commons.api.tomorrow.TomorrowNative.d(Native Method)
	at one.tomorrow.app.commons.api.tomorrow.TomorrowNative$c.a(TomorrowNative.kt:1)
	at one.tomorrow.app.commons.api.tomorrow.TomorrowNative$c.invoke(TomorrowNative.kt:1)
	at one.tomorrow.app.commons.api.tomorrow.TomorrowNative.k(TomorrowNative.kt:1)
	at one.tomorrow.app.commons.api.tomorrow.TomorrowNative.i(TomorrowNative.kt:1)
	at one.tomorrow.app.m.a.x.h.a(FreshChatInitProvider.kt:6)
	at one.tomorrow.app.App.onCreate(App.kt:15)
	at android.app.Instrumentation.callApplicationOnCreate(Instrumentation.java:1189)
	at android.app.ActivityThread.handleBindApplication(ActivityThread.java:6460)
	at android.app.ActivityThread.access$1300(ActivityThread.java:219)
	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1859)
	at android.os.Handler.dispatchMessage(Handler.java:107)
	at android.os.Looper.loop(Looper.java:214)
	at android.app.ActivityThread.main(ActivityThread.java:7356)
	at java.lang.reflect.Method.invoke(Native Method)
	at com.android.internal.os.RuntimeInit$MethodAndArgsCaller.run(RuntimeInit.java:491)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:940)

Ich nutze LineageOS 17.1 (Android 10, Build vom 7. Juli 2021), ohne Google Play Services, dafür mit microG 0.2.19.211515

Die vorherige App-Version (ich bin mir nicht sicher, ob das 2.48.0 oder 2.47.x war) funktionierte problemlos, bis auf den IBAN-Scanner.

Danke! Ist weitergeleitet an Team Android.

1 Like

Danke, ist in Version 2.49.0 gefixed :slight_smile:

2 Like

Vielleicht lag es sogar gar nicht an Euch… Ich hatte einen ähnlichen Fall mit einer anderen App, bei der eine simple Neu-Installation der gleichen Version den Fehler behoben hat:

Die Fehlerbeschreibung ist da durchaus ähnlich. Für alle, die den Aurora Store auf LineageOS ohne Google Play verwenden: Bei so einem Fehler hilft vielleicht eine manuelle Neu-Installation (sogar ohne vorheriges Deinstallieren und damit Datenverlust) oder das Ändern der Installationsmethode im Aurora Store.

1 Like