Feedback zum Android DarkMode

Hallo zusammen,

erst einmal vielen Dank fĂŒr die Bereitstellung des DarkModes in der neuen Android Beta.
Im Prinzip scheint das ja hĂŒbsch auszusehen und standardmĂ€ĂŸig gut zu funktionieren.

Leider ist mir aufgefallen, dass die App nicht mehr funktioniert, wenn sich der DarkMode systemweit ein/ausschaltet (z.B. da der Energiesparmodus angeht oder man ihn durch die Schnelleinstellungen in der Notification Bar Àndert). Denn dann fÀngt der Inhalt der App an neu zu laden, das Design Àndert sich jedoch nicht, also bleibt hell oder dunkel. Auch die Swipe-to-Refresh Geste hilft hier nichts, die Liste wird nicht geladen.
Das ganze sieht dann so aus:

Auch funktioniert der Profilknopf oben rechts nicht mehr, beim Klick darauf passiert nichts, die Tabsleiste unten geht jedoch weiterhin, auch wenn die Pocketseite ebenfalls leer bleibt.

Es hilft nur ein komplettes schließen und erneutes öffnen der App.
Ich kann mir vorstellen, dass dieses Verhalten vor allem nervenaufreibend sein kann, wenn man z.b. gerade eine Überweisung tĂ€tigen will, dann jedoch der Energiesparmodus anspringt und man von vorne beginnen muss etc.

Kurze Infos zum gerÀt, auch wenn ich denke es ist gerÀteunabhÀngig:
Phone: Pixel 3a
Android Version: Q (10)

Viele GrĂŒĂŸe
Lucas

Hi Lucas, bei mir ist der systemweite Dark Mode dauerhaft eingeschaltet, bei dir aber folgt er offensichtlich einer Automatik? Tritt das Problem sowohl von hell nach dunkel als auch von dunkel nach hell auf? Oder nur in eine der beiden Richtungen?

Bin neugierig :smiley:

Hi,

der Fehler tritt in beide Richtungen auf.
Und ja, bei mir geht schaltet sich der DarkMode zusammen mit dem Energiesparmodus ein.

Da im Android 11 ja aber auch Zeitbasierte Automatik möglich sein soll wÀre es gut wenn der Bug bis dahin gefixt ist.

Viele GrĂŒĂŸe
Lucas

1 Like